PHP 5.6 à PHP 7 pour mongodb

Juste un pense bête car ce n’est pas toujours évident quand il faut migrer.
Il faut déjà commencer par installer le nouveau driver via pecl

$ sudo pecl install mongodb

Une fois fait, il faut bien vérifier que le drivers est bien chargé avec par exemple phpinfo().
Si il n’est pas présent il faut vérifier le fichier de configuration (php.ini ou autre) si l’extension est bien chargé.

Pour faire coller au mieux son code existant, il faudra installer 2 librairies.

$ composer install mongodb/mongodb

et pour la rétro-compatibilité qui ré-implémente mongoclient et toute les méthodes devenues obsolètes.

$ composer require alcaeus/mongo-php-adapter
Publié dans Non classé | Laisser un commentaire

Laisser un commentaire